Toyota Corolla Cross Forum banner
1 - 6 of 6 Posts

Registered
Joined
2 Posts
Discussion Starter · #1 · (Edited)
My new cross (L model, 2wd) is 3 weeks old and today in the drive thru the auto stop thing when you press the brake was working then it stopped working 20 seconds after and when I pressed the brakes it said battery charging what does this mean? I called toyota and the lady said it was probably cause my a/c was on. Even though it wasnt. But it has worked before with a/c on. Any idea whats going on. Thanks in advance!! She said to bring it in for them to see tomorrow. The manual said that means the battery charge is low, but how can it be? Its brand new!馃槱
 

Registered
Joined
9 Posts
I think it's normal but worth checking out by the dealer. My Cross came with a bad battery that had to be replaced one week after delivery. :confused:
hi
What were the symptoms of a bad battery on a brand new car?
Also, after replacing the battery, have you still got the same 鈥渓ow battery 鈥 message for the start/stop function? Thanks
 

Registered
Joined
91 Posts
In my case the symptoms were the dreaded "click"! That is, no cranking power at all. After a jump start by Toyota roadside service it again refused to start the next day. Turns out there was a bad cell in the battery that was draining all the power. Any good garage can do a load test on your battery to see if it's bad. Sometimes there will be a parasitic draw from the battery, which may come from an accessory left on or a bad fuse or any number of issues. A bad alternator could also be culprit. Get it checked out.
 

Registered
Joined
9 Posts
In my case the symptoms were the dreaded "click"! That is, no cranking power at all. After a jump start by Toyota roadside service it again refused to start the next day. Turns out there was a bad cell in the battery that was draining all the power. Any good garage can do a load test on your battery to see if it's bad. Sometimes there will be a parasitic draw from the battery, which may come from an accessory left on or a bad fuse or any number of issues. A bad alternator could also be culprit. Get it checked out.
That鈥檚 pretty nasty! Thank God that didn鈥檛 happen to me but I also get the same message 鈥 battery charging 鈥 not always , I also think that the start/stop system has a small separate battery, someone said that to me. My CC came with a crooked stearin wheel, AC lines making a lot of noise and had to be replaced, and also that horrible whistling noise while driving over 40mph. I love the car but for a new car鈥 Everything mentioned above except for the whistling noise, everything was sorted under warranty. I still have the whistling noise and the driver door handle that makes a cracking noise whenever I have a right turn and all the weight goes to the left of the car. Hahaha that鈥檚 weird I know. Last night was very cold and I had to go through a very very very thin black ice鈥 well, next thing I know I lost control of the car and the traction control light goes off and after 2 seconds I got control of the situation. Another situation that never happened before. Thank you for answering me!
 
1 - 6 of 6 Posts
Top